Thank you! Your feedback has been delivered
Thank you! Your feedback has been sent

MongoDB Auth Fail, Code: 8

Hey everyone it seems I ran into a situation and just can't seem to figure it out. After updating to the latest meteor build when I try to start meteor (with a MongoDB hosted at mongolabs.com) I get this error:

=> Meteor server running on: http://localhost:3000/
W2036-23:19:51.718(4)? (STDERR) /root/.meteor/packages/mongo-livedata/45bb567dec/npm/node_modules/mongodb/l                                               ib/mongodb/mongo_client.js:400
W2036-23:19:51.767(4)? (STDERR)               throw err
W2036-23:19:51.767(4)? (STDERR)                     ^
W2036-23:19:51.767(4)? (STDERR) MongoError: auth fails
W2036-23:19:51.768(4)? (STDERR)     at Object.toError (/root/.meteor/packages/mongo-livedata/45bb567dec/npm                                               /node_modules/mongodb/lib/mongodb/utils.js:110:11)
W2036-23:19:51.768(4)? (STDERR)     at /root/.meteor/packages/mongo-livedata/45bb567dec/npm/node_modules/mo                                               ngodb/lib/mongodb/auth/mongodb_cr.js:34:33
W2036-23:19:51.768(4)? (STDERR)     at /root/.meteor/packages/mongo-livedata/45bb567dec/npm/node_modules/mo                                               ngodb/lib/mongodb/db.js:1670:9
W2036-23:19:51.768(4)? (STDERR)     at Server.Base._callHandler (/root/.meteor/packages/mongo-livedata/45bb                                               567dec/npm/node_modules/mongodb/lib/mongodb/connection/base.js:382:41)
W2036-23:19:51.768(4)? (STDERR)     at /root/.meteor/packages/mongo-livedata/45bb567dec/npm/node_modules/mo                                               ngodb/lib/mongodb/connection/server.js:472:18
W2036-23:19:51.768(4)? (STDERR)     at MongoReply.parseBody (/root/.meteor/packages/mongo-livedata/45bb567d                                               ec/npm/node_modules/mongodb/lib/mongodb/responses/mongo_reply.js:68:5)
W2036-23:19:51.769(4)? (STDERR)     at null.<anonymous> (/root/.meteor/packages/mongo-livedata/45bb567dec/n                                               pm/node_modules/mongodb/lib/mongodb/connection/server.js:430:20)
W2036-23:19:51.769(4)? (STDERR)     at EventEmitter.emit (events.js:95:17)
W2036-23:19:51.769(4)? (STDERR)     at null.<anonymous> (/root/.meteor/packages/mongo-livedata/45bb567dec/n                                               pm/node_modules/mongodb/lib/mongodb/connection/connection_pool.js:191:13)
W2036-23:19:51.769(4)? (STDERR)     at EventEmitter.emit (events.js:98:17)
=> Exited with code: 8

Does mongo-livedata need to be updated too? Any help is much appreciated! - David

Note: This question is sponsored by CodersClan and has been copied from Meteor-Talk Google group.

User Gravatar

CodersClan

Posted Oct 14 2013 19:17 UTC

$25


  • Assigned To Conner
  • Solved
  • meteor
    mongodb
  • 1924 Views

1 Replies


EDIT 2: As per the email chain it looks like this was just a string of accidents. Not sure how I had my first issue but it was obviously user error. Glad you got this fix. For any others who read this, check to make sure your database user and password are correct.

EDIT 1: This is very strange, I tested this with meteor -v 0.6.5 and it did not give me the error but on upgrading it did. But I tried deleting my database user user and recreating it with a new password. On doing this I was able to connect with 0.6.6. I have no idea what could have caused this and now I can not recreate the issue... Normally I would say the password or user name was wrong but it I was able to create a 'test' collection with 0.6.5. Let me know if this fixes the issue for you.

I can confirm your issue. Using a new meteor -v 0.6.6.1 app wired up to mongolab, I get:

Meteor server restarted
W2038-22:42:21.242(-4)? (STDERR) /Users/<user>/.meteor/packages/mongo-livedata/45bb567dec/npm/node_modules/mongodb/lib/mongodb/mongo_client.js:400
W2038-22:42:21.242(-4)? (STDERR)               throw err
W2038-22:42:21.243(-4)? (STDERR)                     ^
W2038-22:42:21.245(-4)? (STDERR) MongoError: auth fails

Unfortunately this looks like an issue with livedata itself. Ether there is a bug or the meteor teem changed the api. This does not have anything to do with browser-policy or its siblings as these are opt-in package.

That said you should read the blog release describing the changes they made. Given that they are making way for Galaxy they most likely made a change to meteor startup.

User Gravatar

Conner

Posted Oct 15 2013 19:57 UTC

Solution

This didn't solve your task? Get your own custom solution.

Add a reply

By posting a reply on CodersClan you agree to our Terms & Conditions